Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #185628
    catwingz
    Participant

    Hi,

    The site I am working on is hidden by a ‘coming soon’ page. We just upgraded to the Pro version and there are a bunch of new issues.

    1) this error message is showing on the top and/or bottom of the page(s):

    Warning: Creating default object from empty value in /home/annemeix/public_html/wp-content/themes/high-responsive-pro/inc/customizer/featured-content.php on line 36

    In spite of this I have moved on to creating a child theme so we can continue to use the WP Header Images plugin. This will add a script to the header.php. Hopefully this won’t be a complication.

    2) in spite of having ‘no sidebar’ checked for the home page layout, the sidebar remains.

    3) there is now a large gap between the bottom of the Home page content and the Testimonials. I’d like to know how to close that up.

    4) To make it possible to display header images specific to categories we also upgraded to the Pro version of the WP Header Image plugin. That has made progress and I will be taking this up with him to get the posts in the loop. However, it appears the Pro version of the theme handles header images differently. They are now much shorter/narrower throughout, and the one on the Home page is showing up with a black background. It’s a .png so I can give it a background, but this wasn’t happening with the free theme. Before I change the image I would like to resolve this so the full images are displaying again.

    5) Related to this last, now the page titles of the secondary pages are showing up in their header images. This wasn’t happening in the free version and I need to know what to do to turn off this feature. I have it turned off on the Home page.

    Also, this may belong in a different forum, but the Catch Web Tools social icon widget doesn’t have a logical place to add the social media information. I may track it down before you reply but I thought I should mention it because it appears unfinished.

    Thank you!

    #185650
    Skandha
    Keymaster

    @catwingz: Hello there,

    1. I checked for the issue at my end but did not get the error message.

    2. You might selected a static page as your homepage so you will need to change the Default Layout to change layout of a static homepage.

    3. For this I will need to look into your site. Let me know when your site is accessible.

    4. Both the free and pro version handle the header image the same way. May be there is some other issue that I might be causing this.

    5. I will need to look into your site for this as well.

    I hope this was helpful.
    Let me know when your site is accessible so that I can look into the remaining issues.
    Kind Regards,
    Skandha

    #185864
    catwingz
    Participant

    Hi Skandha,

    I need help with this now because I have to resolve everything before the website can launch. I do have the plugin developer checking into part of this as well.

    1. The error message has disappeared.
    2. The sidebar is still on the home page when it shouldn’t be.
    3. There is an edit link at the top of the Testimonials slider. It’s only possible to see the Home page when logged in, but it’s possible that the big gap above the Testimonials will disappear after launch.
    4. The secondary page header images are now much shorter/narrower throughout, and while the one on the Home page has lost it’s cropped appearance, it is still showing up with a black background. The plugin developer is looking into this as well, as this isn’t supposed to happen.
    5. The page titles in the header remain, and they’ve got to go.

    Thank you

    #186073
    Skandha
    Keymaster

    @catwingz: Hello there,
    I will need to look into your site so that I can debug the issues you are having. For that I will need your WP Admin Credentials. I will contact you shortly by email.

    Kind Regards,
    Skandha

    #186681
    Skandha
    Keymaster

    @catwingz: Hello there,

    2. The option Homepage/Archive Layout works when you have latest posts as your homepage. But if you have a static page as your homepage you will need to use Default Layout option. I have changed your Default Layout to No Sidebar: Full Width.

    3. The Edit link appears only when you are logged in. The big gap above the Testimonials should disappear considerably after site launch. Let me know if you still want the gap to be smaller.

    4. The header image in rest of the pages appears full size like in the homepage if you use Entire Site, Page/post featured image option in Header Image.

    5. The page title seems to be inserted inside the image. So you will need to remove the image to remove the title. It is done in a strange manner.
    <h2 style="background-image: url(http://annemeixner.com/wp-content/uploads/2019/09/Chips-on-a-Board-banner.jpg);">About Anne</h2>
    H2 has both the background image as well as the text.

    Let me know if this helps you out!
    Kind Regards,
    Skandha

    #187416
    catwingz
    Participant

    Hi Skandha,

    This is not going well. I am having to replace images which have disappeared for no reason.

    1. The error message is now appearing when the Customizer is in use. This can’t be a good thing. The header images for the secondary pages are no longer showing in the Customizer.

    2. The objective is to have no sidebar on the Home page but to keep the sidebar on the secondary pages. When I reinstate the sidebar for the rest of the site it also shows on the Home page. The setting enabling the Home page to be different isn’t working. This wasn’t happening with the free version.

    3. We’ll have to see what happens after the launch.

    4. All of the header images are more narrow than when we were using the free version. Tomorrow I’m going to be talking with the plugin author and hopefully he will have a fix for this. The one on the Home page continues to have a black background so I guess I will need to replace the .png with a .jpg.

    5. The page titles are not part of the images so replacing the images won’t solve anything. If it’s being inserted as a background image then it’s part of the Pro version of the theme. This wasn’t happening with the free version. I tried adding this CSS:

    h2.background-image {
    	display: none;
    }

    and also with “!important” but it doesn’t appear to have had any effect. There must be some setting where this is controlled.

    Thank you

    #187553
    catwingz
    Participant

    Hi Skandha,

    This is an update.

    With one exception the problems related to #’s 4 and 5 have been resolved. I disabled the theme header completely and regained control of the size of the header images. The page titles also no longer display on the header images.

    The exception is with the About page which now has two header images. I can’t locate where the extra one is coming from and hope you can help sort this out.

    Thank you

    #193028
    catwingz
    Participant

    Hi,

    The issues related to the error message, Home page sidebar, and double header on the About page are still unresolved. Please advise.

    Thank you

    #194899
    Skandha
    Keymaster

    @catwingz: Hello there,

    1. The error messages seems to be coming due to one of the plugins you are using. Can you try deactivating all your plugin and see if the error message appears?

    2. To have sidebar on rest of the page but not on homepage
    Edit your homepage => On the right sidebar you will see Page Attributes => Select No Sidebar: Full width and Publish

    * Double image on about page
    Adding the following CSS should solve the issue

    body:not(.home) .header-media {
        display:none;
    }

    Let me know if this works out!
    Kind Regards,
    Skandha

    #199531
    catwingz
    Participant

    Hi Skandha,

    We’re making progress.

    1. The error message turned out to be caused by Jetpack. Luckily I had already added a plugin for the most important piece. Problem solved.

    2. I was missing that. Thanks

    3. I am unable to use the CSS but it turns out this is a theme issue. When all of the plugins are deactivated there are only two pages with a header image— the Home page and About. This extra image on About has to go. The other image goes with the Header Image plugin and comes back along with the images for all of the other pages. I am reactivating the plugin for now so it has two again, but I believe the top image is the problem as the actual image doesn’t have good dimensions for a banner.

    Thank you

    #224723
    Skandha
    Keymaster

    @catwingz: Hello there,
    When you deactivate all the plugin only homepage and about page have the header because you have enabled Header Featured Image Options in the About page and you have selected it as your homepage.

    Didn’t the following CSS solve the issue?

    body:not(.home) .header-media {
        display:none;
    }

    Kind Regards,
    Skandha

    #225264
    catwingz
    Participant

    Hi Skandha,

    When I used the CSS before it didn’t help, but one of the changes I’ve made since then must have cleared the way. Now the CSS solves my problem with the About page header image. Thank you for your help.

    #225510
    Skandha
    Keymaster

    @catwingz: Hello there, I hope I was able to resolve your issue. If it’s not too much trouble, I have a quick request: could you please leave an honest review?
    https://wordpress.org/support/theme/high-responsive/reviews/#new-post
    Your review will help others know what to expect when they’re looking for the support I offer. Even a sentence or two would be hugely
    appreciated. Thanks, and if there’s anything else at all that I can do to help, don’t hesitate to let me know. Have a good day! 🙂

    Kind Regards,
    Skandha

Viewing 13 posts - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.