Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #271752
    twillig
    Participant

    Hi there!

    The overview of the posts on my Blog/Post page is displaying the posts only partially:
    – I got a total of 29 published posts properly listed on the wordpress-admin page for Posts >> All Posts
    – On the Blog page though only 10 are displayed:
    Plus: The most recent two aren’t shown on top – even though the dates are chronological correct.
    Plus: On the very bottom of the Blog list there isn’t a button anymore to show “Older Posts”.
    – On the sidebar of the Blog page you even have a correct list of the Recent Posts.

    Settings >> Reading:
    – Blog pages show at most: Initially set to 10. For testing purpose currently set to 99

    The latest post which is displayed is “Watzmann”.
    However after the Watzmann post I’ve published “Hochkoenig” and “Hochstaufen under the moon” – which can be senn on the right in the sidebar.

    Why is that so?
    Skandha, before it will come up anyway: It does not make a difference if I activate or reinstall the recommended plugins. No matter if I turn back on the entire package one by one or all together – the issue stays the same.

    Thanks for helping out!
    Thomas

    #271769
    twillig
    Participant

    Forgot the link for the Blog page: Willig Photography – Blog

    • This reply was modified 1 month, 1 week ago by twillig.
    #271835
    Skandha
    Keymaster

    @twillig: Hello Thomas,

    Maybe you have marked the first two post as Sticky Posts. To check that,
    Edit the first two posts => On the right sidebar you will see an option => Stick to the top of the blog => Make sure it is not checked.

    Let me know if this solves your issue.
    Kind Regards,
    Skandha

    #271866
    twillig
    Participant

    Hi Skandha,

    no, those parameters are all the same on the individual posts. That particular topic is deactivated all the time.
    However, after I was realizing that also posts in between are missing, I noticed that only the posts from the category “Mountaineering” were displayed.

    First idea on my end: To check
    Posts >> Categories >> Parent Category
    That setting is at “None” for all categories though.

    Second test:
    On all posts which were not displayed so far I then activated also the category “Mountaineering”:
    Now they appear properly in the list of posts.

    That however bears the question: What’s so special about category “Mountaineering”?
    Plus: Something odd also appears in the overview of the categories. The checkbox at category “Shootings and Publications” is not shown.

    What’s going on here?

    #272058
    Skandha
    Keymaster

    @twillig: Hello Thomas,
    I checked your site and I can see Hochstaufen under the moon, GER – Nov 2020 as the latest post on your blog. Were you able to resolve the issue?

    Kind Regards,
    Skandha

    #272088
    twillig
    Participant

    Hi Skandha,

    negative.
    Hochstaufen under the moon, GER – Nov 2020 was only showing up in the blog list because I added the category “Mountaineering” to it:
    Category Adventure
    Category Astrophotography and Timelapse
    Category Hiking
    PLUS Category Mountaineering

    Now that I deselected the category Mountaineering from this particular post, it is not showing up on the blog list anymore: http://willigphotography.com/blog/

    This system is going on with in all other cases:
    The selection of this particular category will decide if the post is listed or not.
    Why is that?

    Also please note that all posts are properly displayed once I switch to an alternative theme (for testing purpose “Twenty Twenty-One”.

    #272132
    Skandha
    Keymaster

    @twillig: Hello Thomas,
    I have fixed the issue on your site. Can you please check if the issue resolved?

    Kind Regards,
    Skandha

    #272197
    twillig
    Participant

    Hi Skandha,

    yes, I can confirm that the biggest issue is now solved (listing of all posts on the blog page). Great!
    However, may you please explain what was the reason for it?

    The other point with the missing checkbox for the category “Shootings and Publications” is still open though.
    https://wp.me/a5G5mK-1ul

    In the meanwhile two other friends have had a look at these two issues.
    They are professionally dealing with websites, wordpress and server configurations since many years – and are only raising their eyebrows about it to be honest. They have never experienced such problems which are clearly caused by the Theme.

    Regards,
    Thomas

    #272620
    twillig
    Participant

    Hi Cath-Themes-Team,

    I can only repeat my question from above: May you please explain what was the reason for the issue with the categories?

    Also, once again, the other point with the missing checkbox for the category “Shootings and Publications” is still open:
    http://willigphotography.com/wp-content/uploads/2021/01/Screen-Shot-2021-01-23-at-2.04.23-PM.png

    Screenshot of a missing checkbox

    Looking forward to a decent response.
    Thomas

    #272902
    Skandha
    Keymaster

    @twillig: Hello Thomas,
    The issue was after no Category was selected in the Homepage/Frontpage Options in the customizer.

    Regarding the checkbox issue. I will look into the issue and get back to you soon.
    Kind Regards,
    Skandha

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.