Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #312365
    Kunzibert09
    Participant

    The main menu of my site opens on the PC by hovering the mouse pointer over the individual menu items – so far so intuitive. But since these are individual links without URL, you can click on them in the mobile view without anything happening. To expand the menu, you have to click on the small triangle on the right. I find this relatively unintuitive and would like to change it so that you can open the dropdown by tapping on the name of the parent item.

    Is there a simple solution to this or does this go deeper into the theme?

    I have already found several approaches on the net, but they did not work for my site.

    Many greetings and thanks in advance!

    Daniel

    #312376
    tikaram
    Keymaster

    @kunzibert09 : Can you please post in your site URL so that I can check for issues on your site.

    Regards,
    Tikaram

    #312384
    Kunzibert09
    Participant

    URL: https://www.dosenbier-band.de

    I’m sorry I missed that.

    #312390
    tikaram
    Keymaster

    @kunzibert09 : Login to your WordPress admin section.
    Go to Appearance => Customize => Additional css and add the following css

    @media only screen and (max-width: 1024px) {
      .dropdown-toggle {
        padding-left: 95%;
      }
    }

    Let me know if this helps you out.

    Regards,
    Tikaram

    #312542
    Kunzibert09
    Participant

    Hi,

     

    thanks for your help. Sadly, it doesn’t work.

     

    Greetings.

    #312557
    tikaram
    Keymaster

    @kunzibert09 : I checked your site but it looks like you have not added the additional css that I have provided. Please add the given additional css and clear the browser cache and check again.

    Regards,
    Tikaram

    #312564
    Kunzibert09
    Participant

    Hi,

    I had inserted the CSS. However, I removed it when it didn’t work. I have now put it back in so you can test it.

    Greetings

    #312565
    tikaram
    Keymaster

    @kunzibert09 : Can you please disable the cache plugin on your  site for some time so that I can check for issue on your site.

    Regards,
    Tikaram

    #312572
    Kunzibert09
    Participant

    Sure – done!

    #312573
    tikaram
    Keymaster

    @kunzibert09 : You have error in one of the custom css which you will need to update. The following css code contains one extra closing curly bracket.

    /* Suchleiste aus */
    
    .search-field { display: none !important; }}

    Please replace the css above with the following css and the drop down will work on your site.

    /* Suchleiste aus */
    
    .search-field {
      display: none !important; 
    }

    Let me know if this helps to resolve the issue.

    Regards,
    Tikaram

    #312574
    Kunzibert09
    Participant

    Yes! That fixed it. Thank you very much!

Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.