This topic contains 9 replies, has 2 voices, and was last updated by  Mahesh 3 years, 2 months ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #97206

    KuczekRoss
    Participant

    Originally I had my Blog split into 3 pages (categories). News/Events, Blog, Borderland Member News.

    I found a news widget so now the News/Events and Borderland Member News is under the “News Widget” and Blog is separate as a Blog category.

    If I go to the News/Events or Borderland Member News tabs they look nice. I have the layout set to no sidebar and content width.

    My problem is if I click on any of my News posts the Blog sidebar shows up on the right side. This happens in both News/Events and Borderland Arts News.

    Can you tell me how to turn off the sidebar once I am inside the posts?
    … I still want the sidebar to show up on the Blog page just not these other 2 pages.

    Thanks –

    #97230

    Mahesh
    Keymaster

    @kuczekross: Please post in your site url.

    Regards,
    Mahesh

    #97234

    KuczekRoss
    Participant

    this is my site “http://www.borderlandarts.net”

    #97238

    Mahesh
    Keymaster

    @kuczekross: I just checked your site and seems you are using No Sidebar (Content Width) as the default layout. All other pages are displaying with that particular layout and not the category page. This is kinda strange. I checked for the same on our server and had no such issue. Are you using any plugin? If so, try disabling the plugins and check if that resolves the problem.

    Let me know further.

    Regards,
    Mahesh

    #97242

    KuczekRoss
    Participant

    I am using the widget “WP News and Scrolling Widgets” for both of the problem pages. If I deactivate it will I lose my content?

    Last night I had gone to Appearance > Widget > Optional Post Sidebar and added “Text Widget” which put a white image over the right sidebar. I just took that off so you can see better what I am talking about.

    #97261

    Mahesh
    Keymaster

    @kuczekross: Seems the sidebar is only displaying on the blog page. All other pages is using No Sidebar (Content Width). Its strange, how your blog cateogry page is displaying sidebar. If you do want to make the blog page same layout, you can use the custom CSS. Go to Dashboard=> Appearance=> Customize=> Theme Optoins=> Custom CSS box and add the following CSS:

    .archive.category-blog #main {
        display: block;
        float: none;
        margin: 0 auto;
        width: 820px;
    }
    .archive.category-blog .sidebar-primary {
        display: none;
    }

    Let me know if any problem.

    Regards,
    Mahesh

    #97277

    KuczekRoss
    Participant

    Actually I want to do the opposite of what this code does. This removes the sidebar from the blog but it still shows on News/Events and Borderland Membership News pages.

    I want it to not show up on the News/Event and Borderland Membership News pages. I want to see the Blog Sidebar on the blog page … but that page only.

    It doesn’t make sense why the sidebar also shows up on the other 2 pages.

    When I go to read any of the news posts is where I see the sidebar.

    When you look at this page does the sidebar show up for you?

    News Article

    #97310

    Mahesh
    Keymaster

    @kuczekross: If that’s the case, forget the code above I’ve given above. This can be managed through the metabox in post within the theme itself. Go to the Dashboard=> Posts and edit this post, then scroll down to Gridalicious Options and chose No Sidebar (Content Width) option in Layout Option and then click Update. Do the same for the post you want like this.
    Note: If default layout is set here then it will use the layout you’ve set in Dashboard=> Appearance=> Customize=> Theme Options=> Layout Options‘s Default Layout. This options gives you freedom to choose between different layout for different pages and posts.

    Hope this helps. Let me know if any problem.

    Regards,
    Mahesh

    #97328

    KuczekRoss
    Participant

    That fixed it – Thank you so much!

    I really appreciate the support you give here in the Forums.

    Kathy

    #97331

    Mahesh
    Keymaster

    @kuczekross: Thank you for your appreciation. Have a nice day!

    Regards,
    Mahesh

Viewing 10 posts - 1 through 10 (of 10 total)

The topic ‘2 of my Main Menu tabs show Blog Sidebar’ is closed to new replies.