Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #281055
    tomdkat
    Participant

    Hi! I just upgraded to Photofocus Pro 5.1.3 and received this email notification from WordPress:

    When seeking help with this issue, you may be asked for some of the following information:
    WordPress version 5.7.1
    Current theme: PhotoFocus Pro (version 5.1.3)
    Current plugin:  (version )
    PHP version 8.0.3
    
    Error Details
    =============
    An error of type E_ERROR was caused in line 133 of the file /path/to/site/public_html/wp-content/themes/photofocus-pro/inc/updater/theme-updater-class.php. Error message: Uncaught Error: Attempt to modify property "response" on bool in /path/to/site/public_html/wp-content/themes/photofocus-pro/inc/updater/theme-updater-class.php:133
    Stack trace:
    #0 /path/to/site/public_html/wp-includes/class-wp-hook.php(294): EDD_Theme_Updater->theme_update_transient(false)
    #1 /path/to/site/public_html/wp-includes/plugin.php(212): WP_Hook->apply_filters(false, Array)
    #2 /path/to/site/public_html/wp-includes/option.php(1899): apply_filters('site_transient_...', false, 'update_themes')
    #3 /path/to/site/public_html/wp-content/plugins/wordfence/lib/wfUpdateCheck.php(275): get_site_transient('update_themes')
    #4 /path/to/site/public_html/wp-content/plugins/wordfence/lib/wfUpdateCheck.php(468): wfUpdateCheck->checkThemeUpdates()
    #5 /path/to/site/public_html/wp-content/plugins/wordfence/lib/wfUpdateCheck.php(315): wfUpdateCheck->checkThemeVulnerabilities()
    #6 /path/to/site/public_html/wp-content/plugins/wordfence/lib/wordfenceClass.php(1071): wfUpdateCheck->checkAllVulnerabilities()
    #7 /path/to/site/public_html/wp-includes/class-wp-hook.php(294): wordfence::_refreshVulnerabilityCache(Object(Theme_Upgrader))
    #8 /path/to/site/public_html/wp-includes/class-wp-hook.php(316): WP_Hook->apply_filters(NULL, Array)
    #9 /path/to/site/public_html/wp-includes/plugin.php(484): WP_Hook->do_action(Array)
    #10 /path/to/site/public_html/wp-admin/includes/class-theme-upgrader.php(472): do_action('upgrader_proces...', Object(Theme_Upgrader), Array)
    #11 /path/to/site/public_html/wp-admin/update.php(245): Theme_Upgrader->bulk_upgrade(Array)
    #12 {main}
      thrown
    

    According to the changelog for version 5.1.3, the error above was fixed. Please pass this information on to the Photofocus Pro theme developers.

    Thanks!

    Peace…

    #281070
    tikaram
    Keymaster

    @tomdkat: Thanks for the information. I will forward the message to the development team and let you know soon.

    Regards,
    Tikaram

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.