Tagged: 

This topic contains 8 replies, has 2 voices, and was last updated by  Pratik 3 years, 2 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #97549

    Henriët
    Participant

    Hi team,

    Just submitted the phone field thread, but now opening up a new thread as I’ve got a different topic on Woocommerce, which I really hope you can help me with.
    It appears to be theme-specific, as it doesn’t occur if I use the default wordpress theme (twenty-sixteen).

    Here’s the problem:
    New customers can register at the checkout page. The checkbox for this does indeed appear. However, once I tick it, nothing happens: no fields appear for entering username and/or password.
    Screenshot: http://prntscr.com/c7bjkk
    As you can see, there’s just a blank space. I’ve made the columns a little longer to make sure the fields weren’t hidden by the order-overview below it.

    This is how it looks when using Twenty-sixteen:
    http://prntscr.com/c7bgxw
    Here the fields are clearly there.

    While searching the internet, I came across the following regarding this problem (admittedly, another theme, but perhaps helpful nonetheless):
    https://wordpress.org/support/topic/not-working-on-register-form?replies=32
    …. “Found the issue. WooCommerce in their infinite wisdom uses 2 different systems for the registration, one for checkout, one for the My Account page. The My Account page just uses the built in WordPress registration hooks, which works if the normal [*insert theme-name*] Registration validation is turned on, but doesn’t work if just the WooCommerce one is. Curses!
    Anyway, patches coming for …. ”

    made me think that this may be happening in Gridalicious Pro as well.

    In case you’d like to check on my site (nothing else there but WordPress, Gridalicious Pro and Woocommerce so far) : http://www.gewoonmooigewicht.nl
    I’ve added a test-shop (winkel) from where you can add sth to your cart and then proceed to checkout, to view this problem.

    Could you please have a look at this? Thank you so much!
    Of course I don’t know how they solved it (doesn’t say there), but practically thinking, both instances should just check the woocommerce settings for registration?
    After testing, I can add that the fields don’t show up either if I’ve got the general WordPress registration enabled in Gridalicious Pro. (I’d love to keep these disabled, though).

    Kind regards,
    Henriët

    #97601

    Pratik
    Keymaster

    @gmg-jet:
    Can you update your theme to latest version. The current version is 3.2.1 and you have 1.0.0 in your site.

    Regards,
    Pratik

    #97607

    Henriët
    Participant

    Hello Pratik,

    I do have Gridalicious Pro 3.2.1. running…. the child-version was still set at version 1.0.0 though, didn’t realise I should update that as well! 🙂 Done so now!

    I apologise for the confusion… Thank you for looking into it again!

    Kind regards,
    Henriët

    #97643

    Henriët
    Participant

    Hello Pratik,

    Since the support team usually gives quick answers, but not so this time, I do hope that you didn’t read my reply as if the problem is fixed, for it is not, unfortunately.

    As said, I do use the 3.2.1. Gridalicious Pro version. The 1.0.0. that you saw was only in the name of my child theme – not in the content, which is up to date, as are WordPress and Woocommerce.

    The fields for username and password are displayed when using another theme (default Twenty-Sixteen for example), so the problem is not in either WordPress or Woocommerce; it looks like it is with the Gridalicous Theme.

    In the Gridalicious theme, when an new customer wants to check out, the checkbox for registering a new account shows up: so that conditional works fine.
    However, when the checkbox is ticked, the fields for username and password do not appear. Please see the screenshots in my first post.

    Could you please look into this again and help me out? As right now, my customers will not be able to register on my site.

    Thank you very much for your time!

    With kind regards,
    Henriët

    #97663

    Pratik
    Keymaster

    I was waiting on your reply for the updated version installed or not as you mentioned, you need to check child theme as well.

    I did read your reply and tried it on my server, but everything seems to be working fine on my end.

    Sorry it its taking time because your site is in a different language and it is difficult to navigate for me. But I am working things out.

    The password field appears on my text site, but for some strange reason, does not appear on your checkout page.

    Can you try deactivating/activating the plugin(if you haven’t already)?
    Let me know asap.

    #97668

    Pratik
    Keymaster

    It looks like the password field does not appear initially in your site. Have you used any templates that override WooCommerce Templates?
    I will need to check your child theme too. Can you email it to me at **edited out**?

    Also, try activating the parent theme and see if the problem persists?

    #97673

    Henriët
    Participant

    Hello Pratik!

    Ah that was a miscommunication then… Please don’t think that I was impatient, I know you’re very busy. I just suddenly realised that my reply could be understood as if the problem was solved and I was afraid that you might have seen it that way!

    The only template I’ve overridden was cart.php of woocommerce, and the only thing I’ve done there was remove the two links from image and product name to the product page. Worked perfectly.

    However… very silly of me, but I didn’t check on the parent theme before (only on Twenty-Sixteen…) as all my custon css and custom php went smoothly and did what they were supposed to do.

    Now I did though and I can confirm that the fields do appear in the parent theme. Therefore, the problem must lie within my customisations after all. I’m a bit ashamed of that!
    Before throubling you with my child style.css and child functions.php (which are mostly in English, so no foreign language there ^^), I will remove them completely and re-add them step by step. That way I should discover the culprit.

    I will let you know if/when I’ve found it (or not).

    Thank you so much for your time so far and pointing me in the right direction 😀

    A happy customer,
    Henriët

    #97677

    Henriët
    Participant

    Hello Pratik,

    Just a follow-up 🙂

    I’ve found the piece of coding that caused the conflict.
    It was in reordering/customizing the shipping fields, which share the column with the “create-a-new-account”-button.
    I copied the code from a trusted php developer; it looks like he overlooked this tiny checkbox, accidentally removing some code with it. 🙂 I have contacted him, and hope that he can solve this!

    Thank you very much again for your input that got me in the right direction.
    Since this appears not be related to Gridalicious after all, I won’t bother you about it anymore!

    Kind regards,
    Henriët

    #97684

    Pratik
    Keymaster

    Hi Henriët,

    Thank you for your follow up. As long as the problem is solved, everything’s well.
    Let me know if there are any other theme related issues 😉

    Regards,
    Pratik

Viewing 9 posts - 1 through 9 (of 9 total)

The topic ‘Woocomm.: create acct does not display fields for username and password’ is closed to new replies.