Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #237687
    Dirk
    Participant

    Hi,

    I have the Catch Fullscreen Pro theme. My website is https://www.duneart.nl

    The navigation labels “Next and previous post and Search results for” are not translated to Dutch. I tried to work with the nl-NL po file with poedit free software but I do not know how to add the translation strings to ths file. Can you please advise me how to have those translations done in my theme? Many Thank’s Dirk

    #237745
    Skandha
    Keymaster

    @italianfox: Hello there,
    To add translation strings first of all you will need to use Poedit software. Install and Open the software.

    Create New Translation => Browse and Select catch-fullscreen-pro.pot file from the languages folder and Click Open => Select the language as Dutch(Netherlands).
    Now, Find Previous Post and Next Post strings and add their translation in the Translation Box. Save the file to the theme’s language folder when you are done.

    Now,Go to => Dashboard => Settings => Select Site Language as Nederlands and Save Changes.

    But I suggest you to create a child theme before doing all this as when you update the theme to the newer version the translation you add will be lost or what you can do is you can translate majority of the strings available for translation and email it to me and I shall add it to the theme itself with your name as the contributor.

    Let me know if this helps you out!
    Kind Regards,
    Skandha

    #237778
    Dirk
    Participant

    Hi Skandha,

    Thank you so much for your kind reply. I followed your instructions and even purchased the pro version of Poedit. After saving the po nl file with the new translations, I copied it using Filezilla to the language folder of the theme and I checked in WordPress settings that the language is set to Nederlands.
    Unfortunately on my website the translations for previous post and next post are not changed to Dutch (Nederlands). What can have done wrong?

    #237791
    Skandha
    Keymaster

    @italianfox: Hello there,
    You seem to selected the incorrect language while creating the translation in Poedit.

    When you Create a translation in Poedit software Select the language as Dutch (Netherlands) and the file created should be nl_NL.mo and nl_NL.po. You seem to have selected language as Dutch so the file being created is nl.po and nl.po.

    You can try renaming the nl.po and nl.po files as nl_NL.mo and nl_NL.po and then select site language as Nederlands.

    Let me know if this helps you out!
    Kind Regards,
    Skandha

    #237803
    Dirk
    Participant

    Dear Skandha,

    You are the hero of the day (and the future, ha, ha)

    It works like a charm. I am very greatful to you.

    Many, many thank’s for your time and patience!

    #237850
    Skandha
    Keymaster

    @italianfox: Hello there, I hope I was able to resolve your issue. If it’s not too much trouble, I have a quick request: could you please leave an honest review?
    https://wordpress.org/support/theme/catch-fullscreen/reviews/#new-post
    Your review will help others know what to expect when they’re looking for the support I offer. Even a sentence or two would be hugely
    appreciated. Thanks, and if there’s anything else at all that I can do to help, don’t hesitate to let me know. Have a good day! 🙂

    Kind Regards,
    Skandha

Viewing 6 posts - 1 through 6 (of 6 total)
  • The topic ‘Translate next post/previous post and search results for’ is closed to new replies.