This topic contains 5 replies, has 2 voices, and was last updated by  Sakin 4 years, 2 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #57363

    Wayne
    Member

    Website is http://mHealthTalk.com

    Sidebar content is missing from blog posts but appears fine on pages and archive lists of posts. Under Layout Options, the Default Layout = Content, Primary Sidebar.

    Even if I manually modify Layout Options on individual posts, the sidebar content is missing. Instead, I get what looks like an empty placeholder with no content. Of course if I choose a layout option with No Sidebar, it displays correctly. Is there a different sidebar version for Pages and Posts that I somehow messed up?

    I just installed this Gridalicious Pro theme and have been working on it all day (now 6pm).

    #57388

    Sakin
    Keymaster

    @Wayne: I check in your site and every page has “Sidebar”. So, I am bit confused. Yes that layout option should work fine.

    #57410

    Wayne
    Member

    @Sakin: Yes, the sidebar appears correctly on every PAGE. The problem is that it does not appear on blog POSTS. For example: http://www.mhealthtalk.com/telemedicine-as-good-as-a-doctor-visit/.

    It looks the same with each browser I tried (Safari, Chrome & Firefox), showing what appears to be an empty sidebar devoid of content.

    #57441

    Sakin
    Keymaster

    @Wayne: Sidebar is there in that post as well. But it has empty “Text Widget”. So, you have that color box at the right of your content. So, check your sidebar for empty Text widget. Go to “Appearance => Widget” and see if you have anything is “Optional Post Sidebar”, as this sidebar will replace your primary sidebar in post if you have any active widget there.

    #57462

    Wayne
    Member

    @Sakin: You were exactly right. There was an empty Text widget in the optional sidebar. I just removed it and all is well. ‘Hard to believe I worked so hard on it and the solution was so simple. Boy do I feel embarrassed. Thanks.

    #57463

    Sakin
    Keymaster

    @Wayne: It’s really normal to be in this loop. WordPress theme are easy but yet little confusing sometimes. Thanks 🙂

Viewing 6 posts - 1 through 6 (of 6 total)

The topic ‘Sidebar missing from Posts but appears on Pages & Archive List’ is closed to new replies.