This topic contains 3 replies, has 2 voices, and was last updated by  Mahesh 2 years, 7 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #105206

    Henriët
    Participant

    Hi!

    The following may be related to:
    https://catchthemes.com/support-forum/topic/posts_page-uses-primary-sidebar-while-it-should-use-archive-sidebar/
    (that topic is about sidebar content, this topic is about sidebar place)

    By default Gridalicicous has as its theme layout: primary sidebar – content.
    Today I tried reversing that to content – primary sidebar through the customisation panel.
    This works fine for the (optional) homepage, all other pages, all posts and even post categories.

    However, the optional archive page (for posts) stubbornly puts the primary sidebar first.

    Is there any way to make this page follow the new layout as well?
    I was probably looking in the wrong place when I tried and failed to find a solution for this in the sidebar.php.

    I’m using a child theme, and I’m testing this at: http://test.gewoonmooigewicht.nl
    My optional archive page can be found in the menu under “Blog”.

    Thank you very much for looking into this!

    Kind regards,
    Henriët

    #105210

    Mahesh
    Keymaster

    @gmg-jet: Have you changed the layout option for pages in meta-box in edit page? Go to edit page of the very page, and make sure Default is selected in Layout Option in Gridalicious Options. And click update. I tested on our server and it is working fine.
    Let me know further.

    Regards,
    Mahesh

    #105213

    Henriët
    Participant

    Hello Mahesh,

    thank you very much for your quick reply! I feel so foolish… you are absolutely right.

    Had checked this on posts even though I hardly ever edited/played around with the default layout settings there, but never on this page as I thought it was now automatically generated, having no influence on the layout.
    However, editing the layout was exactly what I had done on this very page when it was still a “normal page” a long time ago, and apparently I had not reset it.

    Reverted it to the default layout, saved it, and of course now it follows the new settings!

    I’m very sorry I troubled you with my sillyness, but I’m also very happy that it is sorted 🙂

    Kind regards,
    Henriët

    #105269

    Mahesh
    Keymaster

    @gmg-jet: Thank you for your appreciation. Have a nice day!

    Regards,
    Mahesh

Viewing 4 posts - 1 through 4 (of 4 total)

The topic ‘Place of sidebar on (optional) archive page’ is closed to new replies.