Viewing 20 posts - 1 through 20 (of 22 total)
  • Author
    Posts
  • #97822
    phillycontemporary
    Participant

    Hi!

    Wondering if it’s possible in anyway to have the featured image slider on a single page that isn’t the homepage–without activating it for the whole site.

    Let me know!

    #97848
    Mahesh
    Keymaster

    @phillycontemporary: Do you mean to just to show slider on single page, or single posts? If so, this can be simply done with Custom CSS. Go to Dashboard=> Appearance=> Customize=> Theme Options=> Custom CSS box and add the following CSS:

    /* On single Post pages only */
    body:not(.single) #feature-slider {
        display: none;
    }
    /* On Sinle Page only */
    body:not(.page) #feature-slider {
        display: none;
    }

    Note: Use only one of above. Do not use both.
    If you want to remove it completely on other pages but display only in single posts/pages (both), then you have to create child theme and customize a bit. You can find more about creating child theme HERE. If you are familiar with programming, I can help you with the code.
    Let me know further.

    Regards,
    Mahesh

    #98004
    phillycontemporary
    Participant

    Hi Mahesh,

    I put in the CSS for the individual page and nothing changed..

    Is it possible to have two different sliders– One on the homepage, and one on a separate page–Both with different featured pages?

    Thank you for all your help! I know I have a lot of questions…

    #98026
    Mahesh
    Keymaster

    @phillycontemporary: Sorry, that’s not possible. You can have only one slider for the entire site. But you can hide the slider where you don’t want it.

    Regards,
    Mahesh

    #98179
    phillycontemporary
    Participant

    If i want to use the code for a single page, do I need to specify the specific page in the CSS?

    I am having difficultly implementing the CSS you provided and getting the slider to show on one page!

    Thank you,

    #98229
    Mahesh
    Keymaster

    @phillycontemporary: Yes.
    Can you please give me the page url in which you want to show the slider. And I’ll provide you the CSS.

    Regards,
    Mahesh

    #98257
    phillycontemporary
    Participant

    Hi!

    I actually just switched to fabulous fluid pro–but if you are still able to help I can email you a guest login for my site (it is not live yet)

    I think I’ve actually already sent you the guest login for my site (philadelphiacontemporary.org) in an old email for a previous question. Let me know if I should resend or re-create this question on the fabulous fluid pro support forum!

    Thank you,

    #98283
    Mahesh
    Keymaster

    @phillycontemporary: I checked your site and do have a login but I cannot access the site since coming soon mode is active and I don’t have the access to change the setting.

    Regards,
    Mahesh

    #98288
    phillycontemporary
    Participant

    Hi,

    Did you use the WP guest login for my site that I sent you previously? It should let you see the site despite the coming soon mode…

    I can re-send the credentials in our old email thread, if that helps!

    #98297
    Mahesh
    Keymaster

    @phillycontemporary: Okay, now I can see your site. Can you please specify in which page you want to enable slider? Or is it just the home page you want to disable the slider in.
    Let me know further.

    Regards,
    Mahesh

    #98319
    phillycontemporary
    Participant

    Hi Mahesh,

    I would like to activate it on the page ‘Projects’

    Thank you for your help!

    #98345
    Mahesh
    Keymaster

    @phillycontemporary: Go to Dashboard=> Appearance=> Customize=> Theme Options=> Custom CSS box and add the following CSS:

    body:not(.page-id-69) #feature-slider {
        display: none;
    }

    Let me know if any problem.

    Regards,
    Mahesh

    #98365
    phillycontemporary
    Participant

    Hi,

    Hmm, I put the code in and I don’t see a change..

    I activated the featured slider for the entire site and put your code into my child theme style sheet. I’m still getting the featured slider on all of my pages. Do I need to ‘disable’ the slider on individual pages in the page layout options?

    #98415
    Mahesh
    Keymaster

    @phillycontemporary: In your child theme, you are using the wrong CSS:

    body:not(.page) #feature-slider {
        display: none;
    }

    It should be:

    body:not(.page-id-69) #feature-slider {
        display: none;
    }

    Regards,
    Mahesh

    #98486
    phillycontemporary
    Participant

    I’ve taken out the wrong code and put in the new CSS you provided, however when I activate the featured slider for the entire site, the slider is still visible on every page.

    I’m using the featured image slider in the featured slider options. Would that make a difference?

    Thank you,

    #98530
    Mahesh
    Keymaster

    @phillycontemporary: I checked your site the code works fine. But the issue is you have put the code inside media query. I have no idea why you are doing so.

    @media screen and (max-width: 782px) {
    }

    If you currently check the site with small display of max width 782px, the slider only appears in projects page.
    So please put the code outside the media query.

    Regards,
    Mahesh

    #98555
    phillycontemporary
    Participant

    Thanks! removing that code fixed it.

    Is it possible to have to slider and the post page exist together?

    After I got the code to work and activated the slider on the single page, it disappeared when I made the page into my static post page. Is there any way to have them together?

    Thank you,

    #98591
    Mahesh
    Keymaster

    @phillycontemporary: Yes, this is possible, you’ll need to specify the page in css in which you want to display it. Let me know if I can help you further.

    Regards,
    Mahesh

    #98624
    phillycontemporary
    Participant

    Hi! Yes, I think I will need help–Or would I just substitute the page id in the previous code you posted with the post page id?

    #98650
    phillycontemporary
    Participant

    I think I’ve figured it out: I’m using

    get_option(‘page_for_posts’)

    in place of my page id.

Viewing 20 posts - 1 through 20 (of 22 total)
  • The topic ‘Featured Image Slider on a single page?’ is closed to new replies.