This topic contains 8 replies, has 2 voices, and was last updated by  tikaram 1 week, 5 days ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #126631

    michelled
    Participant

    I’m using Clean Box and it automatically changes all quotation marks to curly quotation marks. This works fine until I’m blogging about code. If I try to insert a straight quotation mark using the insert special character option, clicking on the straight quote results in no mark entered even though all other marks work. Not sure why this mark is disabled, or how I can fix this. I have a child theme CSS built so if I know where this is I can change it in the child theme, but cannot find the possible culprit. Any thoughts?

    #126654

    tikaram
    Participant

    @michelled : Can you please explain in detail where you are facing this issue (like post,page). Please provide the link where you facing this issue. If you can provide screen shot that would be much appreciated.

    Regards,
    Tikaram

    #126691

    michelled
    Participant

    This happens while posting: as one types a post, if you use the quotation mark key (single or double) the character appears in the post as a straight quote, but in the post itself it appears as a curly quote. As I said earlier, this is fine for most situations but a problem when trying to explain code.

    It started back in April 2015 after an upgrade to WP. Here is one of the original posts right after the problem started: http://mademers.com/image-handling-in-epubs-reaches-new-level-of-inanity/

    It wasn’t a big deal at first and I let it go, but now I need to fix it. And that is how, yesterday, I discovered the straight quote key in the symbols option is malfunctioning. It appears to work (that is, it appears and you can click on it) but no character is added to the post.

    Screenshots: http://mademers.com/wp-content/uploads/quotes-compose.jpg, http://mademers.com/wp-content/uploads/quotes-appear.jpg, http://mademers.com/wp-content/uploads/quotation-mark.jpg.

    #126823

    tikaram
    Participant

    @michelled : Whenever you want to display code on your site you will need to use Preformatted text feature.
    Go to your post and click on edit in WordPress admin. Select the visual tab in the WordPress Editor. Select the code you want to display on your site and click on the drop-down menu where paragraph is written in the menu editor. Select preformatted (Below Heading 6 in drop-down) and save.

    Reference Screen shot : https://www.dropbox.com/s/lirpjhsxjlzf544/preformatted-text.PNG?dl=0

    Let me know if you need any further assistance.

    Regards,
    Tikaram

    #127030

    michelled
    Participant

    Hi Tikaram,

    Thank you but that option creates a new problem: using the Preformatted option places the text in a grey text box with a slider if necessary. This negates the ability, for example, to display code within the context of a regular paragraph. For example:

    No Dual Value
    One cannot add both a width=”100%” and a height=”100%” attribute to the img tag because images are then stretched both ways if necessary to fit the screen. (see http://mademers.com/image-handling-in-epubs-reaches-new-level-of-inanity/).

    Is there no way to fix the issue of not being able to insert a symbol for the straight quotation mark? That strikes me as the simplest solution.

    Regards,
    Michelle

    #127114

    tikaram
    Participant

    @michelled : Let me clarify you first that this functionality is not controlled by theme.Its controlled by WordPress Core and this happens with every WordPress themes. Please take some time to go through this official article from WordPress which explains clearly about the problem that you are facing and the available solutions. Hope this resolves your issue.

    Regards,
    Tikaram

    #127245

    michelled
    Participant

    Thank you for this. I didn’t realise it’s a WP problem.

    #127260

    michelled
    Participant

    Hi Tikram,

    I followed the instructions in the WP blog but now I have a new issue: anything specified as code becomes grey text on a black background.

    In the Clean Box stylesheet, Style.css, there is this:

    code,
    kbd,
    tt,
    var {
    	font: 15px Monaco, Consolas, "Andale Mono", "DejaVu Sans Mono", monospace;}

    Changing it to:

    code,
    kbd,
    tt,
    var {
    	font: 15px Courier, monospace;}

    in my child theme gives me the font I want, but the black box and grey text remain.

    In another file, editor-style.css, there is this:

    code {
    	background-color:#333;
    	color:#ddd;}

    This appears to be the culprit, but deleting it or changing its values does nothing.

    Any ideas?

    #127323

    tikaram
    Participant

    @michelled : Go to Appearance => Customize => Additional css and add the following css

    .entry-content code {
    	background-color: #fff;
    	color: #000;
    }

    Let me know if you have any further issues.

    Regards,
    Tikaram

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.