Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #314495
    rlfloyd
    Participant

    I have the Header Media feature disabled on all pages. For static pages, this works as intended. However, on the page for all my blog posts, it shows a big, blank empty space where the Header Media image would normally show, and also moves the page title so it’s in a different place to all the others and looks inconsistent. I can’t seem to turn this off or remove it.

    See here: https://rianfloyd.com/journal (I’d like this page title to be be the same as all the others).
    I’d also like to be able to remove the calendar/post date only on pages but not on blog posts. I’m not sure what the CSS is just for this.

    Any help appreciated.

    #314498
    tikaram
    Keymaster

    @rlfloyd : To remove the blank empty space : Login to your WordPress admin section.
    Go to Appearance => Customize => Header Media.
    If you have added any text in Header Media Title, Header Media Sub Title and Header Media Text
    please remove it completely and click on publish.
    To remove the calendar and post date from pages please add the following additional css.

    .page .entry-header .entry-meta {
        display: none;
    }

    Let me know if this helps you out

    Regards,
    Tikaram

    #314525
    rlfloyd
    Participant

    Thanks, Tikaram. The post dates from pages has been removed, much appreciated.

    The empty space at the top where the Header Media is, however, is still there. I can confirm there is nothing in the Title, Sub Title and Text sections for Header Media. They are all blank. Any other ideas?

    I’ll clarify again this is just on my posts page, not any other regular pages.

    Thank you

     

    #314698
    rlfloyd
    Participant

    @tikaram Any other suggestions? Could this be a bug, or is it user error on my part?

    #314716
    tikaram
    Keymaster

    @rlfloyd : Please try adding the following additional css.

    body:not(.home) .custom-header {
      padding: 0;
    }

    Please let me know if this helps you out.

    Regards,
    Tikaram

    #314736
    rlfloyd
    Participant

    @tikaram Thank you! This worked a treat. It still shows the title text despite everything being turned off or blank (and the styling and positioning of the title is different to other pages for some reason) so I just set it to display: none. I thought perhaps I could change the padding amount to bump it down the page a little, but it seems there’s a set minimum for anything greater than 0.

    All good, though. At least I know the CSS to tinker with it now. Much appreciated!

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.