Tagged: , ,

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #146605
    dschwartzer
    Participant

    I am using the Free Simple Catch theme and my website is http://appletechtalk.com

    As you probably know, the European Union’s new GDPR law requires explicit consent for storing user’s personal information. If you have comments enabled on a website, then you need to add a comment privacy checkbox to comply with the new law.

    One of the ways WordPress stores and uses personal information is in the comment form. When a user leaves a comment on a website, their name, email address, and website information is stored in a browser cookie. This cookie allows WordPress to automatically fill in user’s information in the comment form on their next visit. With WordPress 4.9.6, the default WordPress comment form will now show a comment privacy opt-in checkbox. Apparently the default WordPress comment form has a check box at the bottom that says:

    “Save my name, email and website in this browser for the next time I comment.”

    All WordPress themes that use the default WordPress comment form will now automatically show this checkbox. I have upgraded to the latest version of WordPress and do not see that on my site so I assume the Simple Catch theme does not use the default Comment form. I see that your demo sites already have this language so I am not sure why I don’t see it on my site.

    I am using a Comment Notifier plugin but I disabled that as a test and the GDRP language still does not appear. Any thoughts on why it is not showing up and suggestions on how to fix it?

    Thank you.

    David

    #146628
    Skandha
    Keymaster

    @dschwartzer: The comment checkbox comes with the latest wordpress version update. You seem to have enabled comments only for logged in or registered users.

    Go to => Dashboard => Settings => Discussion => Other Comment Settings => Uncheck Users must be registered and logged in to comment option

    Let me know if this solves the issue.
    Kind Regards,
    Skandha

    #146633
    dschwartzer
    Participant

    Dear Skandia:

    Thank you for the prompt response. I have unchecked the setting as you suggested and the GSRP text is now there. That said, when the box was checked and someone was logged in, the text did not show up. Also, if you look at the comment box now, you will see that the line to get email notifications (which is controlled by another plug-in) has ben pushed down a couple of rows and the check boxes are on opposite ends of the text.

    Is there a way to get this text to show when the require log in for comments is checked and a way to clean up the appearance of the text?

    If it would help you to be able to log in as a user to trouble shoot this, let me know and ZI can send you a user ID and password via email.

    Thank you,

    David

Viewing 3 posts - 1 through 3 (of 3 total)
  • The topic ‘GDRP Requirements’ is closed to new replies.