Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #150025
    NicolasBassand
    Participant

    Hello,

    I’m using the Catch Wheels theme to build my website. I have a problem with the fonts.
    The automatic font for the titles (heading 1) is Rock Salt.
    My settings are :
    – font Tahoma for the content of my articles
    – font Josefin Sans for all the titles
    Unfortunately, when I click on my articles categories or articles themselves, the page title that appears is written is a weird stylish font that is never my Josefin Sans font nor the Rock Salt font. When I look at the Inspector to see the page code, it seems that the font is recognized at Rock Salt, but it’s not. In the Customization menu, if I try to change the font and use another one, none of them work, as if the font choice for the headings never takes effect.
    Does someone has a solution?

    Thank you in advance for your help!

    Nicolas

    Note: I have the Catch Wheels Pro/Premium theme but I prefer posting my request here in the Free theme section so that anyone can access it.

    #150082
    Skandha
    Keymaster

    @nicolasbassand: There seems to be an issue with the font options. I will get back to you soon on this.

    Kind Regards,
    Skandha

    #150171
    Skandha
    Keymaster

    @nicolasbassand: I checked it again and the font seems to be changing. Can you please check again and let me know if the font are changing?

    Kind Regards,
    Skandha

    #150209
    NicolasBassand
    Participant

    Hi Skandha,
    Thank you for trying to solve my issue. Unfortunately, I tried changing and resetting the fonts several times, it doesn’t work. When I go to Customization > Theme Options > Font Family Options, no matter the fonts I try to use for the titles and the content, there are two elements for which the font never change:
    – the title of the post pages and any regular pages;
    – the body content.

    Best,

    Nicolas

    #150210
    NicolasBassand
    Participant

    Skandha,

    Please see for yourself a page example (article) from my website: http://trustandride.com/serie-le-bol-dor-2017-et-la-magie-de-lendurance-1-6

    In my theme options, the fonts are still set as follows:
    – Tahoma font for the body content
    – Josefin Sans font for all the titles

    As you can see, the title of the page is not written with my font choice Josefin Sans, nor with the automatic Rock Salt font from the theme.

    Also, for the body content, I was wrong in my previous response: I selected the Tahoma font and the body content is correctly written with the Tahoma font.

    Best,

    Nicolas

    #150213
    NicolasBassand
    Participant

    Skandha,

    I finally managed to arrange the issue myself. I looked again at the code of my article pages, and I entered the additional CSS code in my theme:

    h1, h2, h3, h4, h5, h6, .slider-content-wrapper .entry-title, .hero-content-wrapper .entry-title, .promotion-headline-wrapper .entry-title, .custom-header-content .entry-title, .footer-instagram .widget-title, .singular-content-wrap .entry-title {
    font-family: Josefin Sans, sans serif;
    }

    Somehow, despite the font family choice for Josefin Sans in the theme customization, the last line of code above still had Rock Salt as the font family choice.

    Best,

    Nicolas

    #150232
    Skandha
    Keymaster

    @nicolasbassand: I will contact you shortly by email!

    Kind Regards,
    Skandha

    #150358
    Skandha
    Keymaster

    @nicolasbassand: Go to => Appearance => Customize => Additional CSS and add the following CSS Code.

    /*To avoid title breaking to next line */
    .entry-title {
        hyphens:none;
    }

    To remove the space after the excerpt and …
    Go to => Child Theme Folder => open functions.php and add the following code.

    function catch_wheels_custom_excerpt( $output ) {
    		if ( has_excerpt() && ! is_attachment() ) {
    			$more_tag_text = get_theme_mod( 'catch_wheels_excerpt_more_text', esc_html__( 'Continue reading', 'catch-wheels-pro' ) );
    
    			$link = sprintf( '<span class="more-button"><a href="%1$s" class="more-link">%2$s</a></span>',
    			esc_url( get_permalink( get_the_ID() ) ),
    			/* translators: %s: Name of current post */
    			wp_kses_data( $more_tag_text ). '<span class="screen-reader-text">' . get_the_title( get_the_ID() ) . '</span>'
    			);
    
    			$link = '&hellip; ' . $link;
    
    			$output .= $link;
    		}
    
    		return $output;
    	}

    Please update me if the fonts are working or not.

    Let me know if this works out!
    Kind Regards,
    Skandha

    #150531
    NicolasBassand
    Participant

    Hi Skandha,

    Thank you a lot for the additional help!

    I managed to avoid the title break to next line with the additional CSS code provided. It works well. I also made sure there is no break to next line in the content of the articles by adding the following CSS code :

    .entry-content {
    hyphens:none;
    }

    I also entered the code provided in the functions.php file: the removal of the space after the excerpt and before the “…” works well.

    Best regards,

    Nicolas

    #150581
    Skandha
    Keymaster

    @nicolasbassand: Glad I was able to help you out! Have a good day! 🙂

    Kind Regards,
    Skandha

Viewing 10 posts - 1 through 10 (of 10 total)
  • The topic ‘Font for page titles is not the one I have chosen in my font options’ is closed to new replies.